New H5D firmware is now available

by JamesNYCOctober 9. 2013 01:54

Hasselblad will be releasing a new sensor unit firmware version 2.4.3R for all H5D Cameras. At the same time we will also release new firmware for all H5D Camera bodies: H5D131008.hbf.

H5D-40, H5D-50, H5D-50MS and H5D-200MS updating from 1.5.3R:

  • Faster start-up time
  • Technical camera mode (Flash sync and pinhole)
  • Low battery warning on sensor unit display
  • High temperature warning
  • Double click on release button enters menu on sensor unit display
  • Support for GPS module (GIL)
  • Folder view
  • Improved histogram
  • Improved 9-view
  • Language support: English, Spanish, French, German, Italian, Japanese, Chinese

    H5D-60 updating from 2.3.3R:

  • Technical camera mode (Flash sync and pinhole)
  • Language support: English, Spanish, French, German, Italian, Japanese, Chinese

    H5D131008.hbf new features since H5D130506.hbf:

  • Added True Focus functionality when using the H1.7x Converter
  • When using extension tubes or the Macro Converter with True Focus, no focus correction is added and the IFC cursor is always placed in the centre.
  • Added support for the H5D-60
  • Stability improvements
  • Minor GUI corrections
  • Now possible to set ISO on camera grip when tethered.


    Click here to download firmware


    Phocus Quick 1.2.2 Updates for H5D
    _________________

    Phocus Quick 1.2.2 Mac

    Changes
  • Adds support for H5D-60 images

    System Requirements:
    Mac OS X 10.6 or later is required and at least 2GB of memory where 4GB or more is recommended. If you are working with the H4D-60 or H5D-60 we recommend 8GB of RAM. Only Intel processors are supported. For a detailed list of system requirements and possible limitations, please consult the read-me file or user manual.

    Compatibility
    All Hasselblad digital camera products are supported by Phocus Quick.

    __________________

    Phocus Quick 1.2.2 Windows

    Changes
  • Adds support for H5D-60 images

    System Requirements:
    Phocus Quick is supported on Windows XP (SP2 or later), Vista (SP1 or later), Windows 7 and Windows 8 in 64 or 32bit mode. Phocus Quick is optimized for best performance in 64bit mode. For a detailed list of system requirements and possible limitations, please consult the read-me file or user manual.

    Compatibility
    All Hasselblad digital camera products are supported by Phocus Quick.


    Click here to download Phocus Quick

Tags: , , , , , , , , , ,

General

Comments are closed
      Copyright 1998-2013 1ProPhoto.Com All rights reserved.